
 

 
  

201 Daktronics Dr. PO Box 5128 Brookings SD 57006 
Tel 866-343-3122 Fax 605-697-4700 
www.daktronics.com 

Venus® DataStreamer® 
 

Operation Manual 
 
 
 

ED-13649  Rev 10– 22 July 2011 



ED13649 
Product 1260 

Rev 10– 22 July 2011 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

DAKTRONICS, INC. 
Copyright  2003-2011 
All rights reserved. While every precaution has been taken in the preparation of this manual, the publisher 
assumes no responsibility for errors or omissions. No part of this book covered by the copyrights hereon may be 
reproduced or copied in any form or by any means – graphic, electronic, or mechanical, including photocopying, 
taping, or information storage and retrieval systems – without written permission of the publisher. 
 
Galaxy®, DAKTicker®, DataTrac™,DataStreamer®, and Venus® are trademarks of Daktronics, Inc. Windows® is a trademark of Microsoft® 
Corportation.



Table of Contents i 

Table of Contents 

Section 1: Introduction ................................................................................................................. 1 

1.1 System Requirements ............................................................................................................. 1 
1.2 Conventions Used in this Manual ........................................................................................ 1 
1.3 Definitions of Terms ............................................................................................................... 1 
1.4 Functions of the Venus DataStreamer Toolbar ................................................................... 3 
1.5 Help Menu ............................................................................................................................... 5 
1.6 Basic Steps to Using the Venus DataStreamer Software .................................................... 5 
1.7 Contacting Daktronics ............................................................................................................ 6 

Section 2: Installation ................................................................................................................... 7 

Section 3: Configuration .............................................................................................................. 9 

3.1 DAKTicker Display Configuration ....................................................................................... 9 
Rename a Display .......................................................................................................... 12 
Edit a Display ................................................................................................................. 12 
Remove a Display .......................................................................................................... 12 

3.2 Panelized DataTrac Display Configuration ...................................................................... 12 
3.3 Data Driver Configuration ................................................................................................... 14 

Configuring the Financial Driver ................................................................................ 14 
Source Tab ....................................................................................................................... 15 
Configuring the Weather Driver .................................................................................. 15 
Source Tab ....................................................................................................................... 16 
Configuring the MarketWatch News Driver ............................................................. 16 
Source Tab ....................................................................................................................... 17 
Filtering Tab.................................................................................................................... 17 
Configuring the TSN Sports Driver............................................................................. 17 

3.4 Database Driver Configuration ........................................................................................... 22 
3.5 NTP Configuration ............................................................................................................... 25 
3.6 Email Configuration ............................................................................................................. 26 

Section 4: Options ...................................................................................................................... 27 

4.1 Options Tab............................................................................................................................ 27 
Minimizing Venus DataStreamer Software................................................................ 27 
Default Description........................................................................................................ 27 
Ticker Direction .............................................................................................................. 27 
No Results Notification ................................................................................................. 27 

4.2 Email Notification Tab ......................................................................................................... 28 
Setting Email Frequency ............................................................................................... 28 
To Add a Contact ........................................................................................................... 28 
To Remove a Contact..................................................................................................... 29 
To Edit a Contact ............................................................................................................ 29 



ii Table of Contents 

Test Email ........................................................................................................................ 29 
4.3 Image Options Configuration.............................................................................................. 30 

Section 5: Image Explorer .......................................................................................................... 31 

Section 6: Creating Messages for a DAKTicker ....................................................................... 33 

6.1 Creating a New Message ...................................................................................................... 33 
6.2 Adding a Text Frame ............................................................................................................ 34 
6.3 Adding a Time/Date Frame ................................................................................................ 35 
6.4 Adding a DDE Frame ........................................................................................................... 36 
6.5 Adding a Financial Frame .................................................................................................... 38 
6.6 Adding a News Frame ......................................................................................................... 40 
6.7 Adding a Sports Frame ........................................................................................................ 41 
6.8 Adding a Weather Frame ..................................................................................................... 43 
6.9 Adding a Database Frame .................................................................................................... 45 
6.10 Adding an Image Frame ...................................................................................................... 47 

Section 7: Creating Messages for the Panelized DataTrac ..................................................... 49 

7.1 To Create a New Message .................................................................................................... 49 
7.2 Entering a Text Field ............................................................................................................. 50 
7.3 Entering a Time/Date Field ................................................................................................. 50 
7.4 Entering a DDE Field ............................................................................................................ 51 
7.5 Entering Financial Information ........................................................................................... 52 

Entering a Financial Field ............................................................................................. 52 
Entering a Financial Table ............................................................................................ 53 

7.6 Entering a News Table ......................................................................................................... 57 
7.7 Entering a Sports Table ........................................................................................................ 59 
7.8 Entering Weather Information ............................................................................................ 62 
7.9 Entering Database Information ........................................................................................... 63 

Section 8: Conditionals .............................................................................................................. 67 

Type ................................................................................................................................. 67 
Setting the Conditional .................................................................................................. 67 

8.1 Conditionals Defined ............................................................................................................ 68 

Section 9: Playlist Manager ........................................................................................................ 71 

9.1 Adding a Message ................................................................................................................. 71 
9.2 Updating the Display ........................................................................................................... 72 
9.3 Removing a Message ............................................................................................................ 72 
9.4 Blanking the Display ............................................................................................................ 73 
9.5 Saving a Playlist .................................................................................................................... 73 



Table of Contents iii 

9.6 Opening a Playlist ................................................................................................................. 73 
9.7 Scheduling a Message .......................................................................................................... 73 
9.8 Exiting the Playlist Manager ............................................................................................... 74 

Section 10: Venus DataStreamer Troubleshooting ................................................................... 75 

  





Introduction 1 

Section 1: Introduction 

This manual will assist in the installation and operation of the Venus® DataStreamer® software and 
display network. Instructions are included for both DAKTicker® and DataTrac™ displays, sometimes 
in separate sections.  

1.1 System Requirements 
Venus DataStreamer software has the following minimum system requirements: 

• Pentium III 800Mhz or higher 
• 256MB of RAM or higher 
• 50MB Hard disk space 
• Windows 2000 w/SP4, XP Professional w/SP1 required, or Vista, all with most 

recent updates installed. (Windows 95, 98, ME, NT and XP Home are not supported) 
• Other equipment as needed per data source. 
• Available parallel or USB port for software key. 

 
Note: These are minimum PC requirements. In cases where multiple displays and/or data 
sources are used, increasing hardware should be considered to improve performance. 

1.2 Conventions Used in this Manual 
Conventions Used in this Manual 

Bold 
Any item that requires direct action, such as clicking, pressing, selecting, or 
formatting, appears in boldface. Any item within the manual to reference, such as 
a figure or another section, also appears in boldface. 

Italics Indicates an item visible on the screen or within a menu. No direct action will be 
taken on this item. Captions also appear in italics. 

[X] Represents a keyboard key that needs to be pressed. 
“Quotes” Items that need to be typed. 
Click Press and release the left mouse button. 
Double-click Press and release the left mouse button twice. 
Right-click Press and release the right mouse button. 
> Followed by (ex. File > Open). 

1.3 Definitions of Terms 
The following are terms and definitions used throughout the manual and software. 

Apply: Allows changes to take effect without closing the dialog; this is an alternative to OK. 

Cancel: Cancels the last command and closes the window. The [ESC] key on the keyboard 
also performs this action. 

Configure: Defines the size and display type operated with Venus DataStreamer software. 
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Conditional: A set format applied to data when the data satisfies a defined parameter(s). 

Duration: The length of time a frame remains on the display before displaying the next 
frame. This only applies to DataTrac displays. 

Field: A section added to the frame of a message. Fields can contain the following 
information types: Text, Date/Time, DDE, Financial, News, Sports, Weather, or Database. 
This applies only to DataTrac displays. 

Frame: A “page” on the display. A message is composed of one or more frames. 

Monochrome: Displays capable of displaying only one color.  

OK: Executes a command and/or closes the window. This icon can sometimes be activated 
by pressing [Enter] on the keyboard. 

RG: Displays containing red and green LEDs which combine to create amber light. RG 
displays are capable of using any of these three colors for messages.  

RGB: Displays with red, green, and blue LEDs on the modules.  

Table: Allows a variety of information to be displayed in a structured format as shown in 
Figure 1. 

• Field: A 
portion of the 
cell that 
contains the 
specified data 
to be 
displayed. 

• Cell: A 
quadrant of a 
table set up to 
contain a 
certain 
number of 
fields. 

 
Figure 1: Table Dialog 
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1.4 Functions of the Venus DataStreamer Toolbar 
The following items are located on the toolbar of the main screen as shown in Figure 2. This 
section will explain the function of each button. 

 New: Start a new message. 

 Open: Open a previously saved message. 

 Save: Save a message. If the message has not been previously saved, a window will 
appear asking where to save the message and what name to give it. 

 Cut: Remove the selected fields from their current location in the frame of the message 
and place them on the clipboard. 

 Copy: Copy selected fields or text from a message onto the clipboard for use in a 
different message. 

 Paste: Place a copy of the current contents of the clipboard into the frame of a message. 
Items that may be pasted include copies of other Venus DataStreamer data fields, text from 
outside applications, DDE links to DDE compliant applications such as Microsoft Excel, etc. 

 Playlist: Defines the order and the time that messages are run on a selected display. This 
is done after messages have been created and saved.  

  Zoom In/Zoom Out: Zoom In enlarges the contents of a frame by one step per 
click. Zoom Out reduces the contents of the frame by one step per click. 

   Left, Center, and Right Justify: Set the position of text within a field.  

 
Figure 2: Venus DataStreamer Toolbar 
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 About: Provides information about the software. 

 Preview Current Frame/ Play Message Preview/ Stop Message Preview/ 
Pause Message Preview: Used to preview a single frame or an entire message before sending 
the message to the display. 

 First Frame/Previous Frame/Next Frame/ Last Frame: Used for navigation 
between the frames of a message. 

 Add Frame: Add an empty frame to the end of the message. This only applies to 
DataTracs. 

 Copy Frame: Insert a copy of the current frame immediately following the current 
frame. 

 Remove Frame: Remove the current frame from a message. 

The following icons, as shown in Figure 3, are located on the left edge of the main screen. 

 Text: Insert text data into a message. 

 Date/Time: Insert new Date or Time data into a 
message. 

 Dynamic Data Exchange (DDE): Add data gathered 
from other DDE compliant applications such as Microsoft 
Excel. 

 Financial: Insert new financial data into a message. 
Information is collected from external data sources based on 
set parameters. Separate data service registration and fees 
may apply. 

 News: Insert news data into a message. The news 
driver will collect information from external data sources 
based on set parameters. Separate data service registration 
and fees may apply. 

 Sports: Insert new sports data into a message. The sports driver will collect information 
from an external data source based on the set parameters. Separate data service registration 
and fees may apply. 

 
Figure 3: Frame Type Toolbar 
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 Weather: Insert new weather data into a message. The weather driver will collect data 
from external data sources based on the set parameters of the field. Separate data service 
registration and fees may apply. 

 Database: Insert new database data into a message. The database driver will collect 
data from specified databases based on set parameters. 

 Image: Insert new image into a message. 

1.5 Help Menu 
The Help pull-down menu provides two options: Contents and About Venus DataStreamer.  

Contents: The DataStreamer manual information is available under this heading. Double-
click the desired section and 
the sub-sections will be listed. 
Click on the desired sub-
section to go to that text.  

About DataStreamer: This box 
contains information about the 
software, including its version, 
system information, and 
Daktronics contact 
information as shown in 
Figure 4.  

Click OK or press [Enter] to 
exit this dialog. 

1.6  Basic Steps to Using the Venus DataStreamer Software 
This manual is arranged in the basic chronological order used to create and show information 
on a DAKTicker or DataTrac display. In summary, the steps to follow are: 

1. Install the Venus DataStreamer Control Software if it is not already installed on the 
computer. 

2. Configure the display type(s) and the communication method. 
3. Configure external data sources if needed. 
4. Create the message. 
5. Add messages to the display playlist. 
6. Schedule message entries, if desired. 
7. Update the display. 

This manual will walk through the steps necessary to use this display system to its full 
potential. 

 
Figure 4: About DataStreamer Screen 
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1.7 Contacting Daktronics 
If any problems or questions arise that are not discussed in this manual, contact Daktronics 
using any of the following methods: 

Mail: Daktronics Customer Service 
PO Box 5128 
201 Daktronics Drive 
Brookings, SD 57006-5128 

Phone: Customer Service: 800-DAKTRONICS (800-325-8766) 

Fax: 605-697-4700 ATTN: Customer Service 

Website: http://www.daktronics.com 
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Section 2: Installation 

The Venus DataStreamer software must be installed to the hard drive before use. To install the 
software to your computer, follow these steps. 
 
NOTE: PRIOR to installing the Venus DataStreamer software, all USB software keys must be 
REMOVED. Failure to remove the software key will result in deleting of the key. If the software is 
installed without removing the USB key, a new key will have to be ordered from Daktronics 
before the software will be able to run. 
 

1. Place the Venus DataStreamer installation compact disk (CD) into the appropriate CD ROM 
(presume drive D:). 

2. The installation should begin automatically within a few seconds. If it does not, click the Start 
button and select Run from the menu. Type “D:\SETUP” and press [Enter]. 

3. Follow the instructions on the screen. SETUP will copy the files necessary to run the Venus 
DataStreamer software to the hard drive and create Venus DataStreamer in the Start menu.  
Note: The Venus DataStreamer software installs to the C:\Program\Files\Daktronics\Venus 
DataStreamer directory by default. This is the recommended location. 

4. The Venus DataStreamer control software is now installed and ready to be configured for use 
with the Venus DataStreamer displays. 
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Section 3: Configuration 

After installing the Venus DataStreamer software on the computer, the individual displays must be 
configured. The required steps are covered in this section. Refer to Figure 5. 
 

This section provides basic instructions and examples for configuring DAKTickers and DataTrac 
displays that are controlled with the Venus DataStreamer software. 

3.1 DAKTicker Display Configuration 
Displays will need to be configured once the software is installed. To launch the 
configuration window, click the File menu, and then click Configuration (File > 
Configuration). 

1. Click Add New Display and a pop-up window will appear asking what type of 
display is being configured. 
 

2. Click the down arrow to select the DAKTicker. 
 

3. Click OK to move on to the next step or Cancel to void the configuration process. 

 
Figure 5: Main Configuration Window 
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4. Select the type of communication 
that will be used, either "Direct 
Communication" or "Remote 
Communication" as shown in 
Figure 6. Direct consists of a direct 
serial connection from the PC. 
Remote is via a TCP/IP connection 
to the display. 
 

5. Once the communication type is 
selected, fill in any other necessary 
information, (i.e. Com Port or IP 
Address). 
 

6.  Select the Baud Rate from the list provided. Check display documentation for the 
correct baud rate to use.  
 

7. Click Next to accept the entered information and move to the next step or click 
Cancel to void the Configuration process entirely.  
Note: For this example, Direct Communication is chosen. 
 

8. Click the down arrow next to Display Height to set this according to the height of the 
DAKTicker pixels as shown in Figure 7. 
 

9. Click the down arrow next to Color 
Depth to set the type of color 
technology for this display. Default 
setting is Tricolor. 
 

10. Click the down arrow next to 
Direction to determine if the 
information will flow from left to 
right or right to left. The default 
setting for this is right to left.  
 

11. Once these parameters are set, click 
Next to move to the next screen. 
Click Cancel to close the Configure Display Parameters window. 
 

 
Figure 6: Configure Communications Dialog 

 
Figure 7: Configure Display Settings 
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12. Click the down arrow next to 
Display Type and set whether the 
DAKTicker is an indoor display or 
an outdoor display as shown in 
Figure 8.  
Note: It is important to set this 
properly as it will affect the display 
speed. 
 

13. Move the slider bar to set the 
Display Speed at which information 
will travel across the DAKTicker. 
Daktronics recommends a speed of 
90. However, this may need to be 
adjusted depending on the overall 
length of the DAKTicker.  
 

Note: Click and hold the mouse button down on the slider bar to show the speed at which 
the display is currently running. The speed is indicated in columns per second. 

14.  Click the down arrow or click 
within the field to select the Number 
of Displays attached to the display 
network. Click the “>>>” to select 
the addresses of the individual 
displays that will be attached to the 
network. The first display in the list 
will be monitored for the current 
status. Please note: All displays will 
show the same information. Click 
Next to move to the next screen. 
 

15. Enter a name for the display as 
shown in Figure 9. Click Next.  
 

16. The last screen in the Configuration 
shows all the information that was 
entered during configuration as 
shown in Figure 10. Take time to 
review this information. If something 
needs to be changed, click Back to get 
to the correct screen and make 
changes. If everything is correct, click 
Finish to save the configuration.  

 
Figure 8: Configure Display Parameters 

 
Figure 9: Display Name Dialog 

 
Figure 10: Configuration Overview 
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Rename a Display 

Once in the configuration window, a 
display can be renamed if necessary. To 
rename the display, click the desired 
display in the Installed Displays list and 
click Rename Display. The Display Name 
Settings window will appear as shown in 
Figure 11. Enter the new name for the 
display and click OK to save the name or 
click Cancel to void the action.  

Edit a Display 
Once in the configuration window, a display’s properties can be edited. To edit a display, 
click the desired display in the Installed Displays list and click Edit Display. The Configure 
Display Communications window will appear. To make the necessary changes, click Next until 
all changes are made and Finish appears on the last screen. Click Finish to save the changes 
or click Cancel to void the changes. 

Remove a Display 
Once in the configuration window, a display can be removed. To remove a display, click the 
desired display in the Installed Displays list and click Remove Display. The display is 
instantly removed from the Installed Displays list. 

3.2 Panelized DataTrac Display Configuration 
1. Go to the File menu and click Configuration. 

 
2. Click Add Display and a pop-up window 

will appear asking what type of display is 
being configured. 
 

3. Click the down arrow to select the Panelized 
DataTrac as shown in Figure 12. 
 

4. Click OK to move to the next step or Cancel 
to void the configuration process. 
 

 
Figure 11: Renaming a Display 

 
Figure 12: Select Display Type 



Configuration 13 

5. Select the type of communication that will 
be used, either "Direct Communication" or 
"Remote Communication". Direct consists 
of a direct serial connection from the PC. 
Remote uses a TCP/IP connection to the 
display as shown in Figure 13. 
 

6. Once the communication type is selected, 
fill in any other necessary information, 
(i.e. Com Port or IP Address). Click Next 
to accept the entered information and 
move on to the next step or click Cancel to 
void the Configuration process entirely. Note: For this example, Direct 
Communication is chosen. 
 

7. To set Display Dimensions, click the down 
arrow next to each field or click in the 
field to set the overall height and width of 
the Panelized DataTrac as shown in 
Figure 14. The Upper Left Coordinate 
values are typically set to 1 for X and 1 for 
Y. 
 

8. Click the down arrow next to Color Depth 
to set the type of color technology for this 
display. Default setting is Tricolor. 
 

9. Once these parameters are set, click Next to move to the next screen. Click Cancel to 
close the Configure window. 
 

10. Move the slider bar to set the Display 
Brightness level of the information on the 
Panelized DataTrac. Daktronics 
recommends a brightness of 48. 
However, this may need to be adjusted 
depending on different lighting 
conditions. Click Next. 
Note: Clicking and holding the mouse 
button down on the slider bar will cause 
a pop-up window to appear showing 
the brightness level that the current 
display is running. This number will 
change as the slider is moved. 
 

11. Enter a name for the display as shown in Figure 15. Click Next. 
 

 
Figure 13: Configuring Communication 

 
Figure 14: Configure Display Settings 

 
Figure 15: Naming a Display 
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12. The last screen in the Configuration 
shows all the information that was 
entered during configuration as 
shown in Figure 16. Take time to 
review this information. If something 
needs to be changed, click Back to get 
to the correct screen and make 
changes. If everything is correct, click 
Finish to save the configuration.  

3.3 Data Driver Configuration 
Data Drivers provide a means of accessing 
and translating information from external data sources that can be shown via electronic 
displays. These information sources include Financial, Weather, Sports, and News 
subscriptions as well as generic DDE and Database sources. The drivers operate as a 
component of the Venus DataStreamer software, connecting to the data sources and then 
formatting the information to be shown. Since configurations differ by driver type, each is 
explained separately in this section.  

Configuring the Financial Driver 
To configure the Financial driver: 

1. Click File from the pull-down menu and click Configuration. The main 
configuration window will appear. 
 

2. Click the Driver Configuration tab. 
 

3. If registered for this driver source, the box next to it is checked and the configuration 
can proceed. If not currently 
licensed to receive data, please 
contact a Daktronics Sales 
representative for more 
information.  
 

4. If registered, highlight the DTN 
Financial Driver on the left, and 
then click Configure Data Source. 
 

5. Enter the configuration data as 
supplied by Daktronics as shown 
in Figure 17. Set the frequency 
that the information should be 
updated, either by using the down arrow next to the field or by clicking into the field 
itself. 

 
Figure 16: Configuration Overview for DataTrac 

 
Figure 17: Configuring the Financial Driver 
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Source Tab 
Note: The default values set here should only be changed if directed by Daktronics. 

1. Place a checkmark in the Edit box next to 
the field to be changed as shown in 
Figure 18. 
 

2. The selected address field is now active. 
Click in the address field and make 
necessary address changes. 
 

3. Click Apply to complete. 

Configuring the Weather Driver 
To configure the Weather driver: 

1. Click File from the pull-down menu and click Configuration. The main 
configuration window will appear. 
 

2. Click the Driver Configuration tab. 
 

3. If registered for this driver source, 
the box next to it is checked and the 
configuration can proceed. If not 
currently licensed to receive data, 
please contact a Daktronics Sales 
representative for more information.  
 

4. If registered, highlight the DTN 
Weather Driver on the left. Then 
click Configure Data Source. 
 

5. Enter the configuration data as 
supplied by Daktronics as shown in 
Figure 19.  
 

6. Set the frequency that the information should be updated either by using the down 
arrow next to the field or by clicking into the field itself. 

 
Figure 18: Source Tab Dialog 

 
Figure 19: Configuring the Weather Driver 
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Source Tab 
Note: The default values set here should only be 
changed if directed by Daktronics. 

1. Place a checkmark in the Edit box next to 
the field to be changed as shown in 
Figure 20. 
 

2. The selected address field is now active. 
Click in the address field and make 
necessary address changes. 
 

3. Click Apply to complete. 

Configuring the MarketWatch News Driver 
Complete the following steps to configure 
the MarketWatch News driver: 

1. Click File from the pull-down menu 
and click Configuration. The main 
configuration window will appear. 
 

2. Click the Driver Configuration tab. 
 

3. If registered for this driver source, 
the box next to it is checked and the 
configuration can proceed. If not 
currently licensed to receive data, 
please contact a Daktronics Sales representative for more information.  
 

4. If registered, highlight MarketWatch News on the left, and then click Configure 
Data Source. 
 

5. Enter the configuration data as supplied by Daktronics as shown in Figure 21. 
 

6.  Set the frequency that the information should be updated either by using the down 
arrow next to the field or by clicking into the field itself. 

 
Figure 20: Source Tab Dialog 

 
Figure 21: Configuring the MarketWatch Driver 
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Source Tab 
Note: The default values set here should only be changed if directed by Daktronics. 

1. Place a checkmark in the Edit box 
next to the field to be changed as 
shown in Figure 22. 
 

2. The selected address field is now 
active. Click in address field and 
make necessary address changes. 
 

3. Click Apply to complete the changes. 

Filtering Tab 
The Filter list will prevent certain words or 
phrases in headlines from appearing on the display.  

Example: If the word “and” is added to 
the Filter list, every headline containing 
the word “and” will be blocked from 
showing on the display, regardless of 
other content in the headline. 

Click the Filtering tab to view the current 
filter list. Words or phrases can be added 
to the list by typing in the blank field and 
then clicking Add. A word or phrase can 
be removed from the list by highlighting 
the phrase to be removed in the Filter List 
and clicking Remove as shown in Figure 
23. 

Configuring the TSN Sports Driver 
The TSN server provides sports data to the Venus DataStreamer software. 

In order to receive updated schedules each day, the software must be left running 
overnight. Data will be available as it is received from the TSN servers. 

Complete the following steps to configure the TSN Sports driver: 

Configuration Tab 

1. Click File from the pull-down menu and click Configuration. The main 
configuration window will appear. 
 

 
Figure 22: Source Tab for MarketWatch 

 
Figure 23: Filtering Tab Dialog 
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2. Click the Driver Configuration tab. 
 

3. If registered for this driver source, the 
box next to it is checked and the 
configuration can proceed. If not 
currently licensed to receive data, please 
contact a Daktronics Sales representative 
for more information.  
 

4. If registered, highlight the TSN Sport 
Driver and click Configure Data Source. 
The TSN Sport (XML Feed) Properties 
window will appear as shown in Figure 
24. 
 

5. Enter the Username and Password and click Apply. 
 

6. Set the Refresh Schedule by clicking on the scroll buttons to the desired time of day. 
Refresh Schedule is used to determine when the data received the previous day will be 
removed from the display. 
 

Source Tab 

1. Click the Source tab and review the Address and Port Number information. If a 
correction needs to be made, click the Edit boxes next to the Address and Port Number 
field as shown in Figure 25. The fields will become active. Enter the correct IP 
Address and Port number. Daktronics 
provides this information. 
 

2. Click Apply. 
 

Internet tunneling is a process used to access data 
from outside sources by “tunneling through” the 
typical network firewalls and other protective devices 
installed on private networks. Please contact your 
network support staff for assistance with this. 

Note:  If ‘Use Internet Tunneling’ is checked, the 
current internet browser settings will be used for connection to the TSN server.  

• If a proxy server is used for connections to the internet, it must support and allow for 
internet tunneling connections.  

• If internet tunneling connections are not supported, it may be necessary to bypass the 
proxy server to allow connection to the TSN Server on port 4500.  

 
Figure 24: Configuring the TNS Sports Driver 

 
Figure 25: Source Tab for TNS 
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Schedules Tab 

The Schedules tab allows the viewing of game 
schedules for the day sorted by league. 

1. Click the Schedules tab as shown in 
Figure 26. 
 

2. Click the down arrow to select the 
league’s schedule to view. 
 

Note: This is an informational tab only. It won’t 
affect the information viewed on the display. 

Score 

The Score tab allows the choice of leagues from 
which to collect scores. Specific team scores 
within each league can also be selected. 

1. Click the Score tab. 
 

2. Place a check mark next to each of the 
leagues to be monitored as shown in 
Figure 27. 
 

3. Click the button next to each league’s 
name to select the individual teams to 
be monitored. 
 

4. Select the individual teams by 
clicking on each name individually 
with the mouse and clicking Select. 
Or click Select All to choose all of 
the teams as shown in Figure 28. 
 

5. Repeat this process for all leagues 
that are to be monitored. 
 

 
Figure 26: Schedules Tab Dialog 

 
Figure 27: Setting Score Formats 

 
Figure 28: Selecting Teams 
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Standings Tab 

The Standings tab allows the choice of the 
leagues from which standings data will be 
collected.  

1. Click the check boxes next to each 
desired league and click Apply to 
save the settings as shown in Figure 
29.  
 

2. Click OK to close the window or 
click another tab to continue 
configuration. 
 

Leaders 

The Leaders tab allows the choice of league 
leaders' data to be collected as shown in 
Figure 30. 

1. Click the check boxes for each 
desired league and click Apply to 
save the settings. 
 

2. Click OK to close TSN Sport 
Properties window or click the next 
tab to continue configuration. 
 

News 

The News tab allows the choice of sports 
news data to be collected. The number of 
stories to collect for each league can also be 
set. 

1. Click the News tab. 
 

2. Place a check mark next to each of 
the leagues to be monitored as 
shown in Figure 31. 
 

3. Click the button next to each 
league’s name to set the number of news stories to be retrieved. 
 

4. Repeat this process for all leagues that are to be monitored. 
 

 
Figure 29: Standings Tab 

 
Figure 30: Leaders Tab 

 
Figure 31: News Tab 
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5. Click OK to close the TSN Sport Properties window or click another tab to continue 
configuration. 
 

News Filter 

The News Filter list allows certain words or phrases in headlines to be prevented from 
appearing on the display as shown in 
Figure 32. 

Example: If the word “and” is added to the 
Filter list, every headline containing the 
word “and” will be blocked from showing 
on the display, regardless of other content 
in the headline. 

Click News Filter to view the current filter 
list. Words or phrases can be added to the 
list by typing in the blank field and then 
clicking Add. A word or phrase can be 
removed from the list by highlighting the 
phrase to be removed and clicking 
Remove. 

Click OK to accept the changes. 

Odds 

The Odds tab allows the choice of the 
leagues for which odds data will be 
collected as shown in Figure 33. 

1. Click the check boxes next to each 
desired league and click Apply to 
save the settings. 
 

2. Click OK to close TSN Sport 
Properties window or click the next 
tab to continue configuration. 

 
Figure 32: News Filter Setup 

 
Figure 33: Setting the Odds Tab 
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Teams 

The Teams tab allows the displayed names 
of teams in a specific league to be 
customized as shown in Figure 34. 

1. Select the desired league by 
clicking on the down arrow next to 
the league field. 
 

2. Click the team name that will be 
edited. The name will appear in the 
update field below. 
 

3. Click the box Update the Display 
Name and make desired revisions. 

4. Click Update to save the changes. Click Save to complete the Sports Driver 
Configuration. 
 

5. Click OK to close. 

3.4 Database Driver Configuration 
Following are the steps for configuring a Microsoft Access 
Database. To configure other database types, please consult 
the local technical support staff for instructions. 

1. Click the File drop-down menu and click 
Configuration. The main configuration window 
will appear. 
 

2. Click the Driver Configuration tab. 
 

3. Highlight the Database Input driver and click 
Configure Data Source. The Configured Databases 
window will appear as shown in Figure 35.  
 

 
Figure 34: Teams Tab Settings 

 
Figure 35: Configured Databases 
Screen 
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4. Click Add; the Data Links Properties window will 
open as shown in Figure 36. 
 

5. Click Microsoft OLE DB Provider for ODBC 
Drivers.  
 

6. Click Next at the bottom of the screen.  
 

7. Select the option Use Connection String as shown 
in Figure 37. Click Build and the Select Data Source 
window will appear.  
 

8. Click the Machine Data Source tab. Click New. 
The Create New Data Source window will appear as 
shown in Figure 38. Do not change any 
information on this screen. Simply click Next to 
proceed to the next step.  
 

  

 
Figure 36: Setting DataLink 
Properties 

 
Figure 37: Connection Sharing 
Properties 

 
Figure 38: Create New Data Source Dialog 
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9. When the next Create New Data 
Source window appears, select 
Microsoft Access Driver (*mdb) 
and click Next as shown in 
Figure 39. 
A summary window will appear 
showing the data source that has 
been configured. Click Finish to 
complete this portion and 
continue to the next step. The 
ODBC Microsoft Access Setup 
window will appear. 
 

10. Enter a name for the data source 
in the Data Source Name 
field. Enter a description for 
the data source in the 
Description field as shown 
in Figure 40. This 
information is required and 
configuration cannot be 
completed without it. 
 

11. Click the Select button and 
the Select Database window 
will appear as shown in 
Figure 41. Navigate in the 
Directories field to the 
directory where the desired 
database is stored. Select the desired database by clicking on the appropriate name 
under the Database Name field. Click OK to exit the Select Database window and click 
OK again to exit the ODBC Microsoft Access Setup window. 
 

12. Click OK to close the Select 
Data Source window. 
 

13. Click OK to close the Login 
window. Add the 
appropriate authentication 
information. 
 

 
Figure 39: Driver Selection 

 
Figure 40: Naming Data Source 

 
Figure 41: Database Selection 



Configuration 25 

14. The dialog should now be the Data Link 
Properties window with the Connection 
tab selected as shown in Figure 42. Click 
the down arrow under Enter the initial 
catalog to use. The available catalog will be 
the same as the database just configured. 
Select Allow Saving Password. Click the 
database so that it shows in the field 
window. Click Test Connection to verify 
the connection between the data source 
and Venus DataStreamer software or click 
OK to close this window. 
 

15. Enter a name for the database connection 
and click OK. The name for the database 
connection is now listed in the Configured 
Databases window and will be available as 
a data source for the Venus DataStreamer 
software. 
 

16. Close the Configured Databases window by clicking Close. 

3.5 NTP Configuration 
Network Time Protocol (NTP) is an Internet standard protocol that assures accurate 
synchronization of computer clock times to the millisecond in a network of computers. Based 
on UTC, NTP synchronizes client workstation clocks to the U.S. Naval Observatory master 
clocks in Maryland, Washington D.C., and Colorado Springs, CO. If enabled, Venus 
DataStreamer will send periodic time requests to the selected server. 

1. Click the File drop-down menu and click Configuration. The main configuration 
window will appear. 
 

2. Click NTP Configuration. 
 

3. Type the NTP server in the area provided. Note: To find the correct NTP server, go to 
http://tf.nist.gov/service/time-servers.html 
 

4. If desired, check the box by Update Automatically and set the frequency that the 
clock should synchronized. 
 

5. Click Apply to make changes take effect. 
 

Note: If the PC running Venus DataStreamer is located behind a firewall or proxy server 
on the network, it may be necessary to open Port 123 in order for NTP synchronization to 
occur.  

If this is not possible, an internal server will need to be configured. Consult the local 
network administrator for more information. 

 
Figure 42: DataLink Properties Setup 

http://tf.nist.gov/service/time-servers.html�
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3.6 Email Configuration 
Email Configuration sets the parameters that will be used for sending email notifications and 
operating status emails. The setup of email addresses for those receiving these emails is 
explained in Section 4.2. 

1. Click the File 
drop-down menu 
and click 
Configuration. 
The main 
Configuration 
window will 
appear as shown 
in Figure 43. 
 

2. Click the Email 
Configuration tab. 
 

3. Click in the Name 
field and enter the 
name of the 
outgoing email 
account. 
 

4. Click in the Email Address and enter the address of the outgoing email account. (The 
email addresses for those receiving these emails will be entered later. Refer to Section 
4.2. 
 

5. Click in the Outgoing Mail Server field. Enter the address of the SMTP server that will 
be used for sending the email notifications.  
Note: If the server that is being used to send the email requires authentication, check 
the box next to this option to activate the User Name and Password fields.  
 

6. Once all information is entered, click Apply to complete the action. 
 

 
Figure 43: Email Configuration Tab 
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Section 4: Options 

To access the Options window, click the File drop-
down menu and select Options. Two tabs are now 
available for configuring the options as shown in 
Figure 44. 
 
Note: The Email configuration settings from the 
configure dialog must be set up before Email 
Notifications can be set up. Please see Section 3.6 for 
details. 

4.1 Options Tab 

Minimizing Venus DataStreamer 
Software 
A check mark placed in the box next to Minimize to System Tray will allow the software to be 
minimized to the system tray when not in use. Without a check mark, Venus DataStreamer 
will be minimized to the tool bar instead of the system tray. Click in the box to remove a 
check mark. Click OK for the change to take effect or Cancel to close the Options window 
without making any changes. 

Default Description 
The Default Description allows a name for the set of messages to be entered. In some cases, an 
extended description for a message may be needed where the message name may not be 
enough to reflect the content of the message. The message description dialog can be accessed 
while editing a message from the File menu under Set Message Description.  

To name the messages, click in the Description field and type in the desired default. Click OK 
to keep the change or Cancel to void the action. All new messages will have the new default 
description until it is changed again. 

Ticker Direction 
The default direction for the message previewing function can be set here. Click the down 
arrow and select whether the information should move across the ticker from right to left or 
left to right. 

No Results Notification 
If data is not received from the data source, then a notification will appear on the display. 
The text of this notification can be set in the Edit Options window. The default sets this feature 
to N/A. 

 
Figure 44: Options Dialog 
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Click in the No Results Notification field and type in the desired notification message. Click 
OK to keep the change or Cancel to void the action and close the window. 

4.2 Email Notification Tab 
Email notification is used to determine 
who receives email notices and which 
types of notices will be sent. Email must 
be configured prior to the following 
steps. See Section 3.6 

To reach the Email Notifications tab, click 
the File menu and select Options. Once 
the Options window appears, click the 
Email Notification tab as shown in 
Figure 45. 

Click the Enable Email Notification box 
to activate the Email Notification feature.  

Setting Email Frequency 
The frequency of email notifications and status emails can be set up separately. The default 
for status emails is every 60 minutes. The default for email notifications is every minute; 
however, an email will only be sent if notifications are necessary. 

To Add a Contact 
To add a contact to receive Email Notifications, 
complete the following steps: 

1. Click Add and a dialog box will appear 
as shown in Figure 46. 
 

2. Click in the First Name field and type 
the first name of the individual to be 
added to the list. Repeat this process to 
enter the last name of the individual in 
the Last Name field. 
 

3. Place the cursor in the Email Address 
field and type in the email address of the 
recipient. 
 

4. Select which notifications should be sent to the recipient by clicking in the box in 
front of each desired notification. A check mark will appear showing which 
notifications will be sent. 
 

 
Figure 45: Email Notification Tab 

 
Figure 46: Setting Email Contacts 
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The notifications are defined as follows: 

5. Display Notification is sent when communication fails with a display. 
 

6. Data Driver Notification is sent when Venus DataStreamer fails to connect or 
encounters a problem with one or more of the drivers, such as TSN Sports or DTN 
Weather Data. 
 

a. NTP Notification is sent when Venus DataStreamer fails to connect to the 
configured NTP server.  

b. Status Notification is sent to provide status information, serving as a 
“heartbeat” for the control system.  

c. System Notification is sent when Venus DataStreamer starts or shuts down.  

7. Click OK to complete the action or Cancel to void the action and close the dialog 
box. 

To Remove a Contact 
To remove a contact, highlight the name in the Contact list and click Remove. The contact’s 
name and information are immediately removed. 

To Edit a Contact 
To edit a contact, complete the following steps: 

1. Highlight the appropriate name in the 
Contact list and click Edit as shown in 
Figure 47. 
 

2. Click in the necessary fields to make the 
desired edits. Click OK when completed 
or click Cancel to void the action. 

Test Email 
To initiate a test email, click the Test Email 
button. This email will be sent to all the contacts 
listed in the Email Notification dialog.  

 
Figure 47: Changing Email Contacts 
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4.3 Image Options Configuration 
Image Options tells the ticker display what to do when an image tag is not found. For more 
information on using images as shown in Figure 48, refer to Section 5. 

Display Text – shows text that would normally be displayed. For example “Dakt” would 
appear if no image with the 
tag “Dakt” is found. 

Display Default Image – the 
frame type’s default image is 
displayed, refer to Section 5.  

Display Nothing – leaves 
space blank 

 

 
Figure 48: Image Options Tab 
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Section 5: Image Explorer 

To use images as part of a frame, they must first be located on the Internet or other sources and saved 
to a folder on the computer or network. 
 
Daktronics does not provide an image library for 
customer use. 
 
Once images are saved go to File>Image Explorer to 
open the Image Explorer. Go to File>Import>Images 
to add images to the Image Explorer as shown in 
Figure 49. Select folder name to search. Left-click an 
individual image to import it or press and hold the 
control [Ctrl] key while left-clicking multiple images 
to import several at one time. Click open. To filter 
images shown in the Image Explorer window, select 
the drop down list next to Filter and then the 
category of images to view. 
 
Note: For best results, the image should be the same color depth and height as the ticker being used. 
 
Import Image window opens as shown in Figure 50. Select a 
Category, Color Depth and Display Size. Type a tag name in 
the tag name box and click Add Tag. A tag name or names can 
be assigned to each image. Click OK as shown in Figure 50. 
 
Note: When using the financial, news, sports, or weather 
frames, text can be replaced by an image. Under the Appearance 
tab, when creating a message, there is an Image column where 
replacing an image with text can be specified. For example, in 
a financial frame where the Daktronics stock symbol is 
presented, the stock symbol, DAKT can be replaced by an 
image from the Image Explorer that has a tag of DAKT. 
 
When a tag is not found that matches the data to be displayed 
and the Image Options Configuration is set up to use an image, 
the filter category’s default image will be displayed. To set an 
image as the default image, right click on the image and click 
select as default. A star designates the default image as shown 
in Figure 49. To remove the default image attribute from an 
image, right click on the image and click select as default.   
 
To edit an image, select the desired image and click Edit>Image>Edit Image. 

 
Figure 49: Image Explorer Import Dialog 

 
Figure 50: Import Image Dialog 
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Section 6: Creating Messages for a DAKTicker 

The creating and editing of messages takes place within the main screen of the Venus DataStreamer 
software as shown in Figure 51. This is also the location where options can be applied to a message. 
This section explains the step-by-step process of creating and editing messages for a DAKTicker 
display. To create messages for DataTrac displays, refer to Section 7.  

6.1 Creating a New Message  
To start a new message:  

1. Click the New button and a dialog box will appear 
showing a list of display types as shown in Figure 
52. 
 

2. Highlight the appropriate display type and click 
OK. A new message window will appear. 
 

 
Figure 51: Main Message Dialog 

 
Figure 52: Select Sign Type 
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3. Depending on the driver(s) that are installed, several 
different types of information can be entered. When the 
new message window opens, it defaults to Text. To enter 
other types of information, click the appropriate button on 
the left tool bar as shown in Figure 53. Refer to Section 1.4 
for the function of each button. 
 

4. Once all the required fields and information are entered, 
click the Preview button to view the message before 
sending it to the display. Click the Stop button to end the 
preview as shown in Figure 54. Continue to edit or save 
the message. 

6.2 Adding a Text Frame 
Text frames allow simple text information to 
be created for the display. To create a text 
frame, complete the following steps: 

1. Click the Text icon located on the left 
toolbar. The text window will appear 
as a new frame for the message as 
shown in Figure 55. 
 

2. Click in the text field and type the 
message. 
 

3. Click the down arrow next to the 
Color field to select the color of the 
text. 
 

4. Click Justification to choose the desired text alignment. 
 

5. Click the down arrow next to the Background to select the color of the DAKTicker’s 
background. Note: This feature is available only for RGB displays. 
 

 
Figure 53: Frame Type Icons 
on Left Toolbar 

 
Figure 54: Messages Toolbar 

 
Figure 55: Text Frame Dialog 
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6. Click the Font tab to choose the type of font for the message and any other attributes 
the font should have. 
 

7. Click in the Description field to enter the name for this text frame. This helps to 
differentiate between frames. 
 

8. Click the File menu and select Save As and the Save dialog window will appear. 
 

9. Enter a name for the message and click OK to save the message or Cancel to void the 
action. Once the message is saved, it is ready to be sent to the display via the Playlist 
Manager. 

6.3 Adding a Time/Date Frame  
Both Date and Time Frames can be displayed on the DAKTicker. To add either a date or a 
time frame, complete the following steps: 

1. Click the Date/Time icon located on 
the left toolbar. The Date/Time 
window will appear as a new frame 
in the message as shown in Figure 
56. 
 

2. Click the down arrow to set the 
color that the date or time will 
appear. 
 

3. Choose the alignment of the date or 
time field by clicking on the down 
arrow next to the Justification field 
and then choosing Center, Top, or 
Bottom. 
 

4. Choose the background color by clicking on the down arrow next to the background 
field and selecting the desired color. 
Note: This feature is available only for RGB displays. 
 

5. Choose the time zone for the date or time information to be displayed. 
Note: The time displayed will show a 30 to 90 second delay compared to the clock 
on the control computer. 
 

6. Choose the format for the time and/or date to appear. 
 

7. Click the File menu and click Save. 

 
Figure 56: Time and Date Frame 
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6.4 Adding a DDE Frame 
Dynamic Data Exchange (DDE) frames are used to display information from other DDE 
compliant programs such as Microsoft Excel. The following example explains the process as 
it would work for information coming from an Excel spreadsheet.  

To add a DDE frame, complete the following 
steps: 

1. Click the DDE icon located in the left 
toolbar. The DDE window will appear. 
 

2. Enter the name of the application 
which is the source of the information 
to be displayed, in this case, Excel as 
shown in Figure 57. 
 

3. Enter the complete file name (including 
file extensions and worksheet name) of 
the file to be monitored in the topic field. 
 

4. Click the Fields tab and the Fields 
dialog window will appear as shown 
in Figure 58. Fields are similar to the 
rows on a spreadsheet. 
 

5. Create a new entry line for field 
information by clicking on the “+” sign 
to the top right of the dialog box. 
 

6. In the Field area, enter the row 
numbers of the information that will be 
monitored. 
 

7. In the Name field, enter the row number 
of the identifying information for the 
data that is being monitored. 
Note: This can be left blank or used as 
an override field to override the label 
for a set of data associated with a row in 
the spreadsheet. 
 

8. Click the Items tab. The Items window 
will appear as shown in Figure 59. 
 

9. In the Item field, enter the column 
location of the information that is being 
monitored. (Items are similar to columns on a spreadsheet.) 
 

 
Figure 57: DDE Frame Dialog 

 
Figure 58: DDE Fields Tab 

 
Figure 59: DDE Items Tab 
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10. In the Name field of the Items tab, enter the name of each column. 
Note: The DDE, Fields, and Items tabs can be filled in automatically by copying all 
the fields to be monitored from the 
Excel spreadsheet and clicking on the 
Paste Link button. The information 
from the copied fields will fill into 
the corresponding fields in the 
Venus DataStreamer software. 
 

11. Click the Appearance tab to set the 
layout of the information on the 
display as shown in Figure 60. 
 

12. Click the down arrow next to the 
Layout field to select a layout for 
the information on the display. 
When using a custom preset, it 
will be necessary to click the plus 
sign next to the layout field to 
add rows to be formatted. See 
preset examples available for 
DDE frames in Figure 61. 
 

13. Click the arrow next to 
Background to set the 
DAKTicker’s background color. 
Note: This feature is available 
only for RGB displays. 
 

14. Under the Item column, click into 
a field to make the field active. 
Use the down arrow to choose 
the information for the stock to 
show in that field. Repeat this 
step for the fields under Color, 
Font, Format, and Conditional (if 
applicable). Refer to Section 8 
for information on setting conditionals. 
Note: The Justification field is set by the layout that is chosen and cannot be 
changed unless the layout is set to a custom preset. 
 

15. Under Image, click the cell containing NO and click the … button that appears. Check 
the Replace Text with Image box to replace text with an image. Venus DataStreamer 
will look for an image that has a tag matching the text for that field. Please refer to 
Section 5 for further information regarding configuring images with the Image 
Explorer. The size of the image displayed on the ticker can be specified under Image 
Size. Click OK to confirm changes. Yes will appear in the Image column. Note: When 
an image is used, the color, font and format attributes are not used. 
 

 
Figure 60: DDE Appearance Tab 

 
Figure 61: DDE PReseet Layouts 
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16. From the File pull-down menu, click Save As to save the message and information. 
The message is now saved and ready to be sent to the display. 

6.5 Adding a Financial Frame 
Specific information must be entered in order for a financial frame to update and display 
properly. To add a financial frame, complete the following steps: 

1. Click the Financial icon located on the left 
toolbar. The Financial window will appear 
as a new frame in the message.  
Note: For this version of the Venus 
DataStreamer software, the Driver field 
cannot be changed.  
 

2. Click the down arrow next to the field 
Select a Query and select the desired 
query as shown in Figure 62. 
 

3. Click the Data tab and the screen will 
change to show the following window as 
shown in Figure 63. To add Symbol and 
Name fields, click the green plus + in the 
top right of the dialog. 
 

4. Place the cursor into the Symbol field and 
enter the stock symbol of the company 
that is to be displayed. 
 

5. The default name from the data source 
can be replaced, if preferred. Place the 
cursor in the Name field and enter the 
company name to replace the default. 
 

6. Click the Appearance tab to set the 
layout of the information on the display 
as shown in Figure 64. 
 

 
Figure 62: Financial Frame Dialog 

 
Figure 63: Financial Data Screen 

 
Figure 64: Financial Data Appearance Tab 
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7. Click the down arrow next to the Layout field to select a layout for the information on 
the display. See preset examples available for financial frames in Figure 65. When 
using a custom preset, it will be necessary to click the plus sign next to the layout 
field to add rows to be formatted. To 
remove a row, click the “X”. 
 

8. Click the arrow next to Background to set 
the DAKTicker’s background color. 
Note: This feature is available only for 
RGB displays. 
 

9. Under the Item column, click into a field to 
make the field active. Use the down arrow 
to choose the information for each stock 
that will appear in the field. Repeat this 
step for the fields under Color, Font, 
Format, and Conditional (if applicable). 
Refer to Section 8 for information on 
setting conditionals. 
Note: The Justification field is set by the 
layout that is chosen and cannot be 
changed unless the layout is set to a 
custom preset. 
 

10. Under Image, click the cell containing NO and click the … button that appears. 
Check the Replace Text with Image box to replace text with an image. Venus 
DataStreamer will look for an image that has a tag matching the text for that field. 
Please refer to Section 5 for further information regarding configuring images with 
the Image Explorer. The size of the image displayed on the ticker can be specified 
under Image Size. Click OK to confirm changes. Yes will appear in the Image column. 
Note: When an image is used, the color, font, and format attributes are not used. 
 

11. From the File pull-down menu, click Save As to save the message and information. 
The message is now saved and ready to be sent to the display. 

 
Figure 65: Financial Preset Layouts 
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6.6 Adding a News Frame 
Several different categories of up-to-date news headlines can be displayed with Venus 
DataStreamer. To add a News frame, complete the following steps: 

1. Click the News icon from the left toolbar and the News dialog window will open as 
shown in Figure 66. A new frame will be added to the message.  
Note: For this version of Venus 
DataStreamer software, the Driver field 
cannot be changed. 
 

2. Click the down arrow next to the field 
Select a Query to choose a category of 
news headlines. 
 

3. Click the Data tab as shown in Figure 
67. Click the + button to insert the 
parameters for the headlines to be 
shown. This field may change in 
appearance depending on the type of 
query selected on the previous screen. 
 

4. Enter the necessary information for 
each of the fields created. Depending 
on the query selected, this may require 
either the entry of a news source or the 
selection of choices from a drop-down 
list. 
 

5. In the Start column, determine the start 
point for the display information in the 
list of news headings. The Count 
column determines the number of 
news headings to be displayed at a 
time. 
 

6. Click the Appearance tab to set the 
layout of the information on the display 
as shown in Figure 68. See preset 
examples available for news frames in 
Figure 69. 
 

7. Click the down arrow next to the Layout 
field to select a layout for the 
information on the display. When using 
a custom preset, it will be necessary to 
click the plus sign + next to the layout field to add rows to be formatted. To remove a 
row, click the “X”. 
 

 
Figure 66: Choosing a News Frame 

 
Figure 67: News Frame Data Tab 

 
Figure 68: News Frame Appearance Tab 
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8. Click the arrow next to Background to set the DAKTicker’s background color.  
Note: This feature is available only for RGB displays. 
 

9. Under the Item column, click into a 
field to make the field active. Use the 
down arrow to choose the 
information that will show up in that 
field. Repeat this step for to set Color, 
Font, Format, and Conditional (if 
applicable). Refer to Section 8 for 
information on setting conditionals. 
Note: The Justification field is set 
by the layout that is chosen and 
cannot be changed unless the 
layout is set to a custom preset. 
 

10. Under Image, click the cell containing 
NO and click the … button that appears. Check the Replace Text with Image box to 
replace text with an image. Venus DataStreamer will look for an image that has a tag 
matching the text for that field. Please refer to Section 5 for further information 
regarding configuring images with the Image Explorer. The size of the image 
displayed on the ticker can be specified under Image Size. Click OK to confirm 
changes. Yes will appear in the Image column. Note: When an image is used, the 
color, font and format attributes are not used. 
 

11. From the File pull-down menu, click Save As to save the message and information. 
The message is now saved and ready to be sent to the display. 

6.7 Adding a Sports Frame 
A variety of sports information can be displayed with Venus DataStreamer. To add a Sports 
frame, complete the following steps: 

1. Click the Sports icon from the left 
toolbar and the Sports dialog window 
will open as shown in Figure 70. A new 
frame is added to the message. Click the 
down arrow next to Select a Query to 
choose the query type. 

 
Figure 69: News Preset Layouts 

 
Figure 70: Choosing a Sports Frame 
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2. Click the Data tab as shown in Figure 71.  
Note: For this version of Venus 
DataStreamer software, the Driver field 
cannot be changed. 
 

3. Click the + button and insert the 
parameters for showing league data. 
This field may change in appearance 
depending on the type of query selected 
in the previous screen. 
 

4. Enter the necessary information for each 
of the fields created. Depending on the 
query selected, this may require either 
entering information or selecting from a drop-down list of choices. 
 

5. In the Start column, determine the starting point for league data to be displayed. The 
Count column determines the amount of data to be displayed at a time. 
 

6. Click the Appearance tab to set the 
layout of the information as shown in 
Figure 72. See preset examples 
available for news frames in Figure 73. 
 

7. Click the down arrow next to the 
Layout field to select a layout. When 
using a custom preset, it will be 
necessary to click the plus sign + next 
to the layout field to add rows to be 
formatted. To 
remove a row, 
click the “X”. 
 

8. Click the 
arrow next to 
Background to 
set the 
DAKTicker’s 
background 
color.  
Note: This 
feature is 
available only 
for RGB 
displays. 
 

 
Figure 71: Sports Data Tab 

 
Figure 72: Sports Appearance Tab 

 
Figure 73: Sports Preset Layouts 
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9. Under the Item column, click into a field to make the field active. Use the down arrow 
to choose the information to be displayed in that field. Repeat this step for the fields 
under Color, Font, Format, and Conditional (if applicable). Refer to Section 8 for 
information on setting conditionals. 
Note: The Justification field is set by the layout that is chosen and cannot be 
changed unless the layout is set to a custom preset. 
 

10. Under Image, click the cell containing NO and click the … button that appears. Check 
the Replace Text with Image box to replace text with an image. Venus DataStreamer 
will look for an image that has a tag matching the text for that field. Please refer to 
Section 5 for further information regarding configuring images with the Image 
Explorer. The size of the image displayed on the ticker can be specified under Image 
Size. Click OK to confirm changes. Yes will appear in the Image column.  
Note: When an image is used, the color, font and format attributes are not used. 
 

11. From the File pull-down menu, click Save As to save the message and information. 
The message is now saved and ready to be sent to the display. 

6.8 Adding a Weather Frame 
A variety of weather information can be shown on Daktronics displays. To add a Weather 
frame, complete the following steps: 

1. Click the Weather icon from the left 
toolbar and the Weather dialog window 
will open as shown in Figure 74. A new 
frame will be added to the message. 
Note: For this version of Venus 
DataStreamer software, the Driver and 
Query fields cannot be changed. 
 

2. Click the Data tab and enter the zip code 
of the city for which the weather data 
will be retrieved as shown in Figure 75. 
 

3. Click the Appearance tab to set the 
layout of the information on the display 
as shown in Figure 76. 
 

4. Click the down arrow next to the Layout 
field to select a layout for the 
information to appear on the display. 
See preset examples available for 
weather frames in Figure 77. 
 

 
Figure 74: Choosing a Weather Frame 

 
Figure 75: Weather Data Tab 
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5. Click the arrow next to 
Background to set the 
DAKTicker’s background 
color.  
Note: This feature is 
available only for RGB 
displays. 
 

6. Under the Item column, click 
into a field to make the field 
active. Use the down arrow 
to choose the information 
which will show up in that field. Repeat this step for the fields under Color, Font, 
Format, and Conditional (if applicable). Refer to Section 8 for information on setting 
conditionals. 
Note: The Justification field is set by the layout that is chosen and cannot be 
changed unless the layout is set to a custom preset. 
 

7. Under Image, click the cell 
containing NO and click the … 
button that appears. Check the 
Replace Text with Image box 
to replace text with an image. 
Venus DataStreamer will look 
for an image that has a tag 
matching the text for that field. 
Please refer to Section 5 for 
further information regarding 
configuring images with the 
Image Explorer. The size of the 
image displayed on the ticker 
can be specified under Image 
Size. Click OK to confirm changes. Yes will appear in the Image column.  
Note: When an image is used, the color, font and format attributes are not used. 
 

8. From the File pull-down menu, click Save As to save the message and information. 
The message is now saved and ready to be sent to the display. 

 
Figure 76: Weather Appearance Tab 

 
Figure 77: Weather Preset Layouts 
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6.9 Adding a Database Frame 
The Database frame allows information stored on private systems databases to be shown on a 
display. To add a Database frame, complete the following steps: 

1. Click the Database 
icon from the left 
toolbar. The Database 
dialog window will 
open as shown in 
Figure 78 and a new 
frame will be added 
to the message. 
 

2. Click the down 
arrow next to the 
Source field and 
select the 
appropriate 
database. 
Note: Databases must be configured prior to being selected. 
 

3. Click the down arrow next to the Table field and select the appropriate table. 
 

4. Set the starting point for database information to begin. Row one in the table is 
equivalent to the first result. So, if the displayed information is to begin on the 
second row of the table, the starting result should be set to two. 
 

5. Set the number of 
results to be 
displayed from 
the table. If the 
starting result is 
set at two and the 
next fifty rows of 
the table are to be 
shown, then the 
number of results 
should be set at 
fifty. 
 

6. Select the 
Changes Only box to show only the data that have experienced a change in value.  
Note: Binary data types are not supported and will not be displayed. 
 

7. Click the Appearance tab to set the layout of the information on the display as shown 
in Figure 79. 
 

 
Figure 78: Adding a Database 

 
Figure 79:Database Appearance Tab 
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8. Click the down arrow next to the Layout field to select a format for the information to 
appear on the display. When using a custom preset, it will be necessary for the user 
to click the plus sign + next to the 
layout field to add rows to be 
formatted. See preset examples 
available for database frames in 
Figure 80. 
 

9. Click the arrow next to Background to 
set the DAKTicker’s background 
color.  
Note: This feature is available only 
for RGB displays. 
 

10. Under the Item column, click into a 
field to make the field active. Use the 
down arrow to choose the database 
information that will show up in that 
field. Repeat this step for the fields 
under Color, Font, Format, and 
Conditional (if applicable). Refer to 
Section 8 for information on setting 
conditionals. 
Note: The Justification field is set by the layout that is chosen and cannot be 
changed unless the layout is set to a custom preset. 
 

11. Under Image, click the cell containing NO and click the … button that appears. Check 
the Replace Text with Image box to replace text with an image. Venus DataStreamer 
will look for an image that has a tag matching the text for that field. Please refer to 
Section 5 for further information regarding configuring images with the Image 
Explorer. The size of the image displayed on the ticker can be specified under Image 
Size. Click OK to confirm changes. Yes will appear in the Image column.  
Note: When an image is used, the color, font, and format attributes are not used. 
 

12. From the File pull-down menu, click Save As to save the message and information. 
The message is now saved and ready to be sent to the display. 

 
Figure 80: Database Preset Layouts 
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6.10 Adding an Image Frame 
The Image frame is used to display images that are stored on a computer of network. To add 
an Image frame, complete the following steps: 

1. Click the Image icon from the left toolbar. A new Image dialog window will open as 
shown in Figure 81 and a new frame will be added to the message. 
 

2. Click the down 
arrow next to the 
Image File Name field. 
The user can select 
an image from the 
list or they can click 
on <Browse for 
File…> and select 
the location for an 
image. 
 

3. When Fit Image to 
Display Size is 
selected, the height is 
automatically 
changed to the 
display height and 
cannot be changed 
manually. When Fit Image to Display Size is not selected, the user can enter a height 
they would like the image to be displayed. To invert image colors select Invert 
Colors. 
 

4. From the File pull-down menu, click Save As to save the message and information. 
The message is now saved and ready to be sent to the display. 

 

 
Figure 81: Adding a Frame 
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Section 7: Creating Messages for the Panelized 
DataTrac 

Creating and editing messages takes place within the main screen of the Venus DataStreamer 
software as shown in Figure 82. This screen also contains the tools used to apply different options to 
a message. This section will explain the step-by-step process for creating or editing a message for a 
Panelized DataTrac display. To create messages for a DAKTicker, refer to Section 6. 

7.1 To Create a New Message  
To start a new message:  

1. Click the New button. A dialog box will 
appear as shown in Figure 83. 
 

2. Highlight the appropriate display type and 
click OK. A new message window will 
appear. 
 

3. Depending on the type of driver(s) that are 
installed, several different types of 
information can be entered. To enter 
information, click the appropriate icon on the 
left tool bar. 
 

 
Figure 82: DataTrac Main Dialog 

 
Figure 83: Selecting Display 
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4. Once all the required fields and information are entered, click the Preview button to 
view the message before sending it to the display as shown in Figure 84. Click the 
Stop button to end the preview and continue to edit or save the message. 

7.2 Entering a Text Field 
Text fields allow simple text information to 
be shown on the display. To create a text 
field, complete the following steps: 

1. Create a new message window or 
open an existing message and click 
the Text icon from the left toolbar. 
The text dialog window will appear. 
 

2.  Click in the text field and type 
the message as shown in Figure 
85. 
 

3. Click the Display tab to set the 
color and alignment of the text 
within the field. Click OK to 
complete or Cancel to void the 
action. 
 

4. Click the File menu and select 
Save and the Save dialog 
window will appear. 
 

5. Enter a name for the message and click OK to save the message or Cancel to void the 
action. Once the message is saved, it is ready to be sent to the display via the Playlist 
Manager. 

7.3 Entering a Time/Date Field 
Both date and time fields can be displayed on the 
DataTrac. To enter either a date or time field in a 
frame, complete the following steps: 

1. Click the Date/Time icon located on the 
left toolbar. The Date/Time window will 
appear as shown in Figure 86. 
 

2. Choose the time zone for the date/time 
information to be displayed. 
 

3. Click the Display tab to set the color of 
the information. Click the down arrow 

 
Figure 84: Messages Toolbar 

 
Figure 85: DataTrac Text Field 

 
Figure 86: Date/Time Dialog 



Creating Messages for the Panelized DataTrac 51 

next to the color field and then click the desired color. 
 

4. Within the Display tab, choose the alignment of the date field by clicking on the down 
arrow next to the Justification field and click Center, Top, or Bottom. Refer to Section 8 
for information on setting conditionals. 
 

5. Click the File menu and select Save As. The Save As dialog window will appear. 
Enter a name for the field and click OK. The message is now saved. 

7.4 Entering a DDE Field 
Dynamic Data Exchange (DDE) fields are used to display information from other DDE 
compliant programs such as Microsoft Excel. The following example will use information 
coming from an Excel spreadsheet.  

To add a DDE field, complete the following 
steps: 

1. Click the DDE icon located in the 
left toolbar. 
 

2. In the Application field, enter the 
name of the program from which 
the information is coming (Ex: 
Excel) as shown in Figure 87. 
 

3. Enter the complete file name of the 
file to be monitored in the Topic 
field (including file extensions and 
worksheet name).  
 

4. In the Item field, enter the location of the data in the source program. For example, in 
a spreadsheet situation, enter the row and column of the information to be displayed. 
For instance, data being pulled from row 1 
column A would be entered as R1C1. 
 

5. Click the Display tab and the Display 
dialog window will appear as shown in 
Figure 88. 
 

6. Select the text color by clicking on the 
down arrow next to the color box. Repeat 
this process to set the Justification of the 
information. Refer to Section 8 or 
information on setting conditionals. 
 

7. Click the Format tab and the Format dialog window will appear as shown in Figure 
89. 
 

 
Figure 87: Inserting DDE Field 

 
Figure 88: DDE Display Tab 
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8. In the Format window, set the information 
style by highlighting the desired format on 
the left side of the screen. 
 

9. On the right side of the screen, set the 
parameters for the chosen format.  
 

10. Click OK for the format to be applied. 
Click Cancel to void the action and close 
the DDE window. 
 

11. Click the File drop-down menu and click 
Save. Enter a name for the message being 
saved and click OK. The message is now ready to be sent to the display. 
 

Note: A DDE field may also be created by copying the desired fields and pasting them into 
the DataTrac message window. This will automatically fill in the Application, Topic, and Item 
fields. The DDE fields can then be edited as desired. 

7.5 Entering Financial Information  
Financial information can be entered either in a field or a table. Both options are explained in 
this section.  

Entering a Financial Field 
Specific information must be entered in a Financial field in order to update and display 
information properly.  

To add a Financial Field, complete the following steps: 

1. Once a new message window is open, click the 
Financial icon located on the left tool bar. The 
message dialog window will change to the 
financial mode as shown in Figure 90.  
Note: Set the driver and the query field at this 
time. 
 

2. Place the cursor in the field next to Symbol and 
enter the financial symbol of the company to be 
monitored. 
 

 
Figure 89: DDE Format Tab 

 
Figure 90: Financial Field Tab 
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3. Click the down arrow next to Select a Field to set the query information. This function 
allows the selection of data to be displayed for a stock index. For example, today’s 
high, low, last price, or the change of a 
stock price may be selected. 
 

4. Click the Display tab to set the color and 
alignment of the financial information as 
shown in Figure 91. Refer to Section 8 for 
information on setting conditionals. 
 

5. Click the Format tab to set the parameters 
of the information as shown in Figure 92. 
For example, if the data will be displayed 
in numerical form, the number of decimal 
places can be set here. 
 

6. From the File pull-down menu, click Save 
to save the message and information. The 
message is now ready to be sent to the 
display. 
 

7. Repeat the above steps as necessary to 
create and place all desired fields.  

Entering a Financial Table 
Occasions may arise when it is necessary to know 
which stocks are performing in a specific manner, 
for example, which stocks are most active. The Financial Table Wizard allows the user to select 
a financial exchange, such as the NYSE, and set the criteria for monitoring that exchange.  

To create a Financial Table, complete the following steps: 

1. Open a new DataTrac window in the Venus DataStreamer software.  
 

2. Right-click within the new message 
window and a pop-up menu will 
appear. Click New and Financial 
Table. The Financial Table Wizard 
will appear as shown in Figure 93. 
 

3. Click Next. 
 

4. Click the down arrow next to the 
Query field and select the desired 
query information as shown in 
Figure 94. 
 

 
Figure 91: Financial Display Tab 

 
Figure 92: Financial Format Tab 

 
Figure 93: Financial Table Wizard 
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5. Click in the Value field and enter the symbol of the exchange to be monitored, for 
example, NYSE for New York Stock Exchange. Click Next. 
 

6. Click the up and down arrows next to 
the Table Width field to set the number 
of columns the table will contain as 
shown in Figure 95. Repeat this step in 
Table Height to set the number of rows 
the table will contain. Click Next. 
 

7. Click the up and down arrows to set 
the width and height of each cell 
within the table. Click Next. 
 

   
Figure 94: Financial Data Source Dialog 

 
Figure 95: Table Dimensions Dialog 
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8. Click in the first field under the Field column in the table and select the information 
to be displayed in that field of the table as shown in Figure 96. 
 

9. In the Line and Character 
columns, choose the line 
and character on which 
the field should be 
displayed within each 
cell. For example, line 1 is 
the very top line of the 
defined cell and character 
2 is the second column 
from the left of the 
defined cell. 
 

10. Click in the Width column 
to set the maximum 
number of characters 
available for the field to 
be displayed. 
 

11. Click in the Height field to set the number of rows used to display the information. 
Note: If a field is wider than the allowed width, set the height higher than one and 
the data will wrap into the additional rows. 
 

12. Click in the Justify and Color columns to set the appearance of the data in the field. 
 

13. Click in the General column to set any necessary parameters for the field. 
 

14. The Conditions field allows the monitoring of data and the modification of values 
according to certain criteria. Refer to Section 8 for information on setting 
conditionals. 
 

15. Click Next. 
 

  

 
Figure 96:Field Configuration Dialog 
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16. To Show Only Specific Results, 
click this radio button as shown 
in Figure 97. Then click on the 
up and down arrows next to the 
Starting Result and Number of 
Results fields, selecting the 
starting result for the table and 
the number of results to be 
displayed.  
OR 
To show Page Results, set the 
Paging Interval for reports with 
several results which will rotate 
through the display, for 
example: NYSE Most Actives. 
Note: The Page Results option 
allows all the results for a query to be displayed. 
 

17. Click Next. 
 

18. The Financial Table overview will show all of the criteria that have been selected for 
the table as shown in Figure 98. Use the scroll bar on the right to see all the 
information. If anything needs to be changed, click the Back button to reach the 
necessary screen and make the appropriate changes. Otherwise, click Finish to close 
the Wizard and finish creating the table. Or click Cancel to void the table. Once the 
table is complete, click File > Save to save the table.  

 
Figure 97: Result Configuration 

 
Figure 98: Financial Table Overview 
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7.6 Entering a News Table 
A variety of news headlines can be displayed on a Daktronics DataTrac. Follow these steps to 
set up news headlines for display.  

1. To display news data, click the News icon 
from the left toolbar. The News Table Wizard 
will open as shown in Figure 99. Click 
Next. 
 

2. Use the down arrow next to the Data Source 
and Query fields to determine the type of 
news stories that will be as shown in the 
news field as shown in Figure 100. The 
parameter will change depending on the 
type of Query that is chosen. Under the 
Value field, enter the appropriate 
information as determined by the 
parameter field. Click Next. 
 

3. Click the up and down arrows next to the 
Table Width fields to set the number of 
columns the table will contain as shown in 
Figure 101. Repeat this step in Table Height 
to set the number of rows the table will 
contain. Click Next. 
 

4. Click the up and down arrows to set the 
width and height of each cell within the 
table as shown in Figure 102. Click Next. 
 

5. In the Field Configuration dialog as shown in 
Figure 103, click in the Field column and 
select the information to be displayed in 
that field of the table. 
 

6. In the Line and Character columns, choose 
the line and character on which the field 
should be displayed within each cell. For 
example, line 1 is the very top line of the 
defined cell and character 2 is the second column from the left of the defined cell. 
 

 
Figure 99: News Table Wizard 

 
Figure 100: Selecting a News Source 

 
Figure 101: Selecting Table Dimensions 
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7. Click in the Width column to set the 
maximum number of characters to be 
displayed in the field. 
 

8. Click in the Height field to set how 
many rows will be used to display the 
information. 
Note: If a field is wider than the 
allowed width, set the height higher 
than one and the data will wrap onto 
the additional rows. 
 

9. Click in the Justify and Color columns to set the appearance of the data in the field. 
 

10. Click in the General column and 
set any necessary parameters for 
the field. 
 

11. The Conditions field allows data 
to be monitored and values 
modified according to certain 
criteria. Refer to Section 8 for 
information on setting 
conditionals.  
 

12. Click Next. 
 

13. To Show Only Specific Results, 
click on that radio button. Then 
click the up and down arrows 
next to Starting Result and Number of 
Results, selecting the result on which 
the table will start and the number of 
results to be displayed as shown in 
Figure 104.  
OR 
To show Page Results, set the Paging 
Interval for reports with several results 
to be rotated through the display, such 
as Top Stories.  
Note: The Page Results option allows 
all the results for a query to be 
displayed. Click Next. 
 

 
Figure 102: Setting Cell Dimensions 

 
Figure 103: Setting Field Configurations 

 
Figure 104: Result Configuration 
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14. The News Table overview will 
show all of the criteria 
entered as shown in Figure 
105. Use the scroll bar on the 
right to review all 
information. If anything 
needs to be changed, click 
the Back button to reach the 
necessary screen and make 
appropriate changes. 
Otherwise, click Finish to 
close the Wizard and 
complete creating the table. 
 

15. Click File > Save to keep the 
changes made or click 
Cancel to void the action and close the Wizard. 

7.7 Entering a Sports Table 
A variety of sports headlines can be displayed on a Daktronics DataTrac. To display sports 
data, use the Sports Table Wizard as described here. 

Complete the following steps: 

1. Click the Sports icon from the left 
toolbar. The Sports Table Wizard will 
open. Click Next to begin creating a 
sports field as shown in Figure 106. 
 

2. Use the down arrow next to the Data 
Source and Query fields to determine the 
type of sports query that will be shown 
in the sports table. The parameter will 
change depending on the type of Query 
chosen. Under the Value field, enter the 
appropriate information as determined by the parameter field as shown in Figure 
107. Click Next. 
 

 
Figure 105: News Table Overview 

 
Figure 106: Sports Table Wizard 
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3. Click the up and down arrows next to 
the Table Width field to set the number of 
columns which the table will contain as 
shown in Figure 108. Repeat this step in 
Table Height to set the number of rows 
the table will contain. Click Next. 
 

4. Click the up and down arrows to set the 
width and height of each cell within the 
table as shown in Figure 109. Click 
Next. 
 

5. Click under the Field column in the table 
and select the information to be 
displayed in that field of the table as 
shown in Figure 110. 
 

6. In the Line and Character columns, 
set the line and character which the 
field should display within each 
cell. For example, line 1 is the very 
top line of the defined cell and 
character 2 is the second column in 
from the left of the defined cell. 
 

7. Click in the Width column to set the 
maximum number of characters 
available for the field to be 
displayed. 
 

8. Click in the Height field to set the 
number of rows to be used for 
displaying the information. Note: 
If a field is wider than the 
allowed width, set the height 
higher than one and the data will 
wrap onto the additional rows. 
 

9. Click in the Justify and Color 
column to set the appearance of 
the data in the field. 
 

 
Figure 107: Sports Data Source Dialog 

 
Figure 108: Setting Table Dimensions 

 
Figure 109: Sports Cell Dimensions 
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10. Click in the General column 
and set any necessary 
parameters for the field. 
 

11. The Conditions field allows 
data to be monitored and 
values to be modified 
according to certain criteria. 
Refer to Section 8 for 
information on setting 
conditionals. Click Next. 
 

12. To Show Only Specific 
Results, click that radio 
button as shown in Figure 
111. Then click the up and down 
arrows next to the Starting Result 
and Number of Results fields to 
select the starting result for the 
table and the number of results 
to be displayed.  
OR 
To show Page Results, set the 
Paging Interval for reports with 
several results to rotate through 
the display. 
Note: The Page Results option 
allows all the results for a query 
to be displayed, such as all NFL 
scores. Click Next. 
 

13. The Sports Table overview will 
show the criteria that were 
entered as shown in Figure 112. 
Use the scroll bar on the right 
to review all the information. If 
anything needs to be changed, 
click the Back button to reach 
the necessary screen and make 
appropriate changes. 
Otherwise, click Finish to close 
the Wizard and complete 
creating the table. 
 

14. Click File > Save to keep the 
criteria selected or click Cancel 
to void the action and close the 
Wizard. 

 
Figure 110: Sports Field Configuration 

 
Figure 111: Sports Result Configuration 

 
Figure 112: Sports Table Overview 
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7.8 Entering Weather Information 
A variety of weather information can be displayed using Venus DataStreamer software. To 
add a Weather field, complete the following steps: 

1. Click the Weather icon from the left 
toolbar and the Weather dialog 
window will open as shown in Figure 
113 
Note: For this version of Venus 
DataStreamer software, the Driver 
and Query fields cannot be changed. 
 

2. Place the cursor in the field to the 
right of Zip Code and enter the zip 
code of the city to be monitored. 
 

3. Select the Field to be displayed by 
clicking the down arrow and 
highlighting the desired query. 
 

4. Click the Display tab and choose the 
color and justification of the 
information as shown in Figure 114. 
Refer to Section 8 for information on 
setting conditionals. 
 

5. Click the Format tab and set the 
parameters of the weather 
information as shown in Figure 115. 
 

6. Click File > Save. The dialog window 
will appear. 
 

7. Enter a name for the message and 
click OK to complete the action or 
click Cancel to void the action.  

  

 
Figure 113: Weather Field Dialog 

 
Figure 114: Weather Display Tab 

 
Figure 115: Weather Format Tab 
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7.9 Entering Database Information 
Database information stored in private database systems may also be shown on a display. To 
show database information, complete the following steps. 

1. Click the Database icon from the left 
toolbar and the Database Table Wizard 
will open as shown in Figure 116. Click 
Next. 
 

2. Click the down arrow next to the Source 
field and select the appropriate database 
as shown in Figure 117. (Note: 
Databases must be configured prior to 
being selected. Refer to Section 3.4.) 
 

3. Click the down arrow next to the Table 
field and select the appropriate table. 
 

4. Click the up and down arrows next 
to the Table Width field to set the 
number of columns the table will 
contain as shown in Figure 118. 
Repeat this step in Table Height to set 
the number of rows the table will 
contain. Click Next. 
 

5. Click the up and down arrows to set 
the width and height of each cell 
within the table as shown in Figure 
119. Click Next. 
 

6. In the Field Configuration dialog, 
enter the Number of Fields to be 
located in each cell as shown in 
Figure 120. Click in the first field 
under the Field column and select the 
information to be displayed in that 
field of the table. 
 

7. In the Line and Character columns, 
choose the line and character on 
which the field should be displayed 
within each cell. For example, line 1 
is the very top line of the defined cell 
and character 2 is the second column 
from the left of the defined cell. 
 

 
Figure 116: Database Table Wizard 

 
Figure 117: Database Source Selection 

 
Figure 118: Setting Table Dimensions 
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8. Click in the Width column to set the maximum number of characters available for the 
field to be displayed. 
 

9. Click in the Height field to set the 
number of rows that will be used to 
display the information. 
Note: If a field is wider than the 
allowed width, set the height higher 
than one and the data will wrap onto 
the additional rows. 
 

10. Click in the Justify and Color columns 
to set the appearance of the data in the 
field. 
 

11. Click in the Format column 
to set any necessary 
parameters for the field. 
 

12. The Conditions field allows 
data to be monitored and 
values to be modified 
according to certain criteria. 
Refer to Section 8 for 
information on setting 
conditionals. Click Next. 
 

13. To Show Only Specific 
Results, click that radio 
button as shown in Figure 
121. Then click the up and 
down arrows next to the 
Starting Result and Number of 
Results fields, selecting the result on which the table will start and the number of 
results to be shown. 
OR 
Click the Page Results portion of the screen and set the Paging Interval for reports 
with several results to rotate through the display. The Page Results option allows all 
the results for a query to be displayed. 
 

 
Figure 119: Setting Cell Dimensions 

 
Figure 120: Setting Field Configurations 
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14. The Database Table 
overview will show the 
criteria that were 
entered as shown in 
Figure 122. Use the 
scroll bar on the right to 
review all of the 
information. If anything 
needs to be changed, 
click the Back button to 
reach the necessary 
screen and make the 
appropriate changes. 
Otherwise, click Finish 
to close the Wizard and 
complete creating the 
table. Click File > 
Save to save the 
message. 

 

 
Figure 121: Database Result Configuration 

 
Figure 122: Database Table Overview 
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Section 8: Conditionals 

Conditionals allow the user to define parameters that will modify the data shown on a display versus 
the actual incoming data when the condition has been satisfied. If incoming data does not meet the 
defined parameters as set by the conditionals, then the incoming data is displayed without any 
changes. Multiple conditionals can be applied to the incoming data as shown in Figure 123. To set a 
new conditional, click the plus sign +. To remove a conditional, highlight it and click the “X”. A 
maximum of six conditionals can be applied per field. 
 

Conditionals work on an If/Then formula. For example, when displaying financial data, if the value of 
the incoming data is equal to the set parameter, then the data will be changed according to the 
definition of the conditional. 
 
To set conditionals, follow these guidelines for the fields in the Conditions dialog.  

Type 
The Type of conditional determines the format of the data when compared to the parameters 
of the conditional. The format that is applied when displayed is determined by what is set in 
the format field within the Appearance tab. General is the default setting and applies no 
specified format to the incoming data. 

Setting the Conditional 
When the incoming data meets the conditional parameters, then the data will be displayed 
with the conditional formats applied. The conditional formats include alternative text and/or 
change of color. 

To set text, complete the following:  

1. Click in the Set Text box. 
 

2. Click in the field next to Set Text to activate the cursor. 
 

 
Figure 123: Conditionals Window 
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3. Type desired text. 
 

To set the text color, complete the following: 

1. Click in the Set Color box. 
 

2. Click in the field next to Set Color to activate the color field. 
 

3. Click the down arrow to select the desired color. 
 

Comparisons can be performed between fields in the selected data source or with a literal 
value. If a literal value is used for comparison, it must be enclosed in quotes or the Venus 
DataStreamer software will look for a field with that name.  

Example: If comparing two fields and the Type is left as General: Value 1 is “1” and Value 2 is 
“01”. While numerically they are the same value, in a general or text comparison, the “01” 
value would be greater. 

8.1 Conditionals Defined 
The available conditionals are defined as follows: 

Equal to– If the value of the incoming data is equal to the set parameter, then the data will be 
displayed with the conditional format applied. 

Not equal to– If the value of the incoming data is not equal to the set parameter, then the 
data will be displayed with the conditional format applied. 

Greater than – If the value of the incoming data is greater than the set parameter, then the 
data will be displayed with the conditional format applied. 

Greater than or equal to – If the value of the incoming data is greater than or equal to the set 
parameter, then the data will be displayed with the conditional format applied. 

Less than – If the value of the incoming data is less than the set parameter, then the data will 
be displayed with the conditional format applied. 

Less than or equal to – If the value of the incoming data is less than or equal to the set 
parameter, then the data will be displayed with the conditional format applied. 

Between – If the value of the incoming data equals the two set parameter numbers, or any 
number in between, then the data will be displayed with the conditional format applied. 

Not between – If the value of the incoming data does not include the two set parameter 
numbers or anything in between, then the data will be displayed with the conditional format 
applied. 

Contains – If the value of the incoming data contains the set parameter, then the data will be 
displayed with the conditional format applied. 
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Does not contain – If the value of the incoming data does not contain the set parameter, then 
the data will be displayed with the conditional format applied. 

Matches – If the value of the incoming data matches the set parameter, then the data will be 
displayed with the conditional format applied. 

Does not match – If the value of the incoming data does not match the set parameter, then 
the data will be displayed with the conditional format applied. 
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Section 9: Playlist Manager 

The Playlist Manager is responsible for sending saved messages to the server. A list of messages 
currently running on a display will also be provided along with a list of all configured displays. 
 

The Playlist Manager is divided into two parts as shown in Figure 124. The left side of the Playlist 
Manager dialog shows the configured display list and the right side shows the currently scheduled or 
running messages. 
 
The Playlist Manager has several functions that include: 
 

• Adding messages to a display. 
• Removing messages from a display. 
• Blanking the display. 
• Updating the display. 
• Scheduling messages. 

 
Each of these functions is explained in this section. 

9.1 Adding a Message 
Once a message is created and saved, it can be shown on the display. Click the Playlist 
Manager button located on the top tool bar in the main window of Venus DataStreamer to 
activate this. Or click File > Playlist Manager to launch the Playlist Manager window. 

To add messages to the display playlist, complete the following steps: 

 
Figure 124: Playlist Manager Dialog 
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1. Highlight the desired display from the left side of the screen. 
 

2. Click Add Message and the dialog box will open. 
 

Navigate to the folder where the message is saved as shown in Figure 125. 

3. Highlight desired messages. 
 

4. Click OK to complete the action or Cancel to void the action and close the window. 
 

5. Click Update Display to add the message to the display playlist. 

9.2 Updating the Display 
Once a message is added or removed from the playlist, the display must be updated before 
the changes will take effect. This is accomplished by clicking Update Display. During the 
next rotation of running messages, the message list will be updated. 

The circle to the left of a message will display three colors, red, green, and gray. The 
following list defines the colors: 

• Red – Message has not been added to the display. 
• Green – Message has been added to the display and is currently running. 
• Gray – Message is in the rotation but is not currently displayed.  

9.3 Removing a Message 
Unique messages may be created for a specific reason, such as announcing an upcoming 
event. After the events have expired, these messages can be removed from the display.  

Complete the following steps to remove a message from the display: 

1. Highlight the message to be removed from the message list by clicking on it once. 
 

 
Figure 125: Select Message for Playlist 
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2. Click Remove Message. The message will instantly be removed from the play list; 
however, until Update Display is clicked, the message will continue to be shown. 

9.4 Blanking the Display 
By clicking on Blank Display, all running messages will be immediately removed from the 
display. This includes scheduled messages as well. 

Any or all of the messages can be shown on the display again by going through the steps of 
adding a message. Refer to Section 9.1. 

9.5 Saving a Playlist 
A playlist can be saved and stored in a display’s library. 

To save a playlist: 

1. Click the Playlist Control tab (in the center of the dialog) and select Save. A dialog 
window will appear. 
 

2. Select the library where the playlist will be saved. 
 

3. Enter the name of the playlist in the File Name field. 
 

4. Click OK to finish saving the playlist or Cancel to void the action. 

9.6 Opening a Playlist 
A previously saved playlist is easily opened again from the display’s library. 

1. Click the Playlist Control tab and then Open.  
 

2. An Open File dialog window will appear. Navigate to the library where the desired 
playlist is saved and select it. 
 

3.  Click OK to open the playlist. 

9.7 Scheduling a Message 
Situations may arise when a message needs to run at specific times of the day or the week. 
The scheduling capability of the Playlist Manager can be utilized for this purpose. 

To schedule a message, complete the following steps: 

1. Place a check mark in the box next to the message to be scheduled by clicking on it 
once with the mouse. This will activate the other scheduling fields. 
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2. Click in the Start Time field and adjust the start time of the message by either typing 
in the time or using the up and down arrows on the right. Repeat the same procedure 
for the Stop Time field. 
Note: The scheduled start time must be earlier in the day than the stop time or the 
message will not be shown 
 

3. Click into the First Date and type the date the message should start using the 
mm/dd/yyyy format. Repeat this process for the Last Date. 
Note: The scheduled start date must be earlier in the year than the stop date or the 
message will not be shown. 
 

4. Place a check mark under the days of the week on which the message should be 
displayed. 
 

5. Click Update Display for the changes to take effect and the message will be 
effectively scheduled. 
 

Note: The schedule may not begin to run at the exact start time. This occurs because the 
buffer in the controller needs to be allowed to display all messages before the schedule can 
start. Once the buffer is cleared, the schedule will begin running. 

9.8 Exiting the Playlist Manager 
To exit the Playlist Manager, click the X in the upper right corner of the screen. 
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Section 10: Venus DataStreamer Troubleshooting 

This section contains some symptoms that may be encountered while using Venus DataStreamer 
software and possible remedies for each situation. This list does not include every possible issue, but 
does represent some of the more common situations that may occur. If a problem should occur that is 
not covered here, contact Daktronics Customer Service at the number listed on the cover page of the 
manual. 
 
Problem Observed Possible Solutions 

The display is set up in the software, but I cannot 
communicate with my display. The display is blank. 

• Check power to the display. Verify this by 
unplugging the display’s power cord and then 
plugging it back in. The display should boot up 
and show its initialization sequence. 

• Check that the data cable is connected from the 
signal converter to the input connection on the 
display.  

• Check that the cable is a flipped cable. 
• Check that the address in the software matches 

the hardware address (for DAKTickers only). 

I’m using a Lantronix serial server to connect to my 
display. All the cables are connected correctly and the 
address in the software matches that of the sign. The 
display has power and boots up but I still cannot 
connect. 

• Check that the Lantronix serial server is set up for 
the correct connect mode (either RS-422 or RS-
232). 

• Verify that the baud rate is 9600 for a DAKTicker 
display or 19200 for a DataTrac display. 

• Check that the socket on the Lantronix serial 
server matches the socket in the configuration 
(The software default is 3001). Refer to ED-12850 
for more information on setting the baud rate and 
changing the socket. 

I do not see the names of the stocks, only the stock 
prices. 

• Under the Appearance tab in the message screen, 
check that Name is in the Item list and not 
[NAME]. Name shows the name of the stock while 
[NAME] displays an alternative user name. It is 
most likely that the [NAME] field was left blank 
beside the stock index. (Refer to Section 6.5 for 
help.) 

A portion of the display does not display data. 
• Refer to the display manual troubleshooting 

section. 
My DataTrac display boots up fine and I can send 
messages to it, but no data appears on the display. 

• Check the configuration of the display. Make sure 
the coordinates are set to X=1, Y=1. 

No Data Driver appears in the Data Driver field. 
• Check that a data driver was configured in the 

Configuration dialog. 

I cannot set the address for a DataTrac. 
• The address cannot be set for a DataTrac. The 

data is broadcast to all displays on the network. 
 

http://portal.daktronics.lan/docs/manuals/Manuals/4/ED-12850-Rev4.pdf�
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